Google, Shopify and others experiencing degraded performance affecting Tapcart's Dashboard

Incident Report for Tapcart

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:18 UTC

Update

Monitoring Shopify downtime: https://www.shopifystatus.com/incidents
Monitoring Google downtime: https://status.cloud.google.com/
Posted Jun 12, 2025 - 19:07 UTC

Monitoring

Google Cloud Platform and Shopify are experiencing an outage and degraded performance
Posted Jun 12, 2025 - 18:48 UTC
This incident affected: Tapcart Merchant Dashboard.